FAQ  |  Search  |  Register  |  Profile  |  Log in to check your private messages  |  Log in

Preconfigured PHP 5.2.8 for Windows

 
Post new topic   Reply to topic    Aprelium Forum Index -> PHP
View previous topic :: View next topic  
Author Message
admin
Site Admin


Joined: 03 Mar 2002
Posts: 718

PostPosted: Thu Dec 11, 2008 5:35 pm    Post subject: Preconfigured PHP 5.2.8 for Windows Reply with quote

Dear all,

PHP 5.2.8 has been released yesterday and fixes a major bug in 5.2.7: http://www.php.net/ChangeLog-5.php .

The preconfigured PHP 5.2.8 package for Windows is available from: http://www.aprelium.com/data/php528.exe .

Please give it a try and let us know if it works fine for you.

The installation instructions are similar to those in http://www.aprelium.com/abyssws/php5win.html with one major exception: Type must be set to Standard

READ THIS IF YOU ARE UPGRADING:

If you are upgrading from an old preconfigured PHP package do not forget to set Type to Standard in the interpreter declaration.

MacOS X version:

It takes more time to package and we do not expect to have it ready it before a few days.
_________________
Forum Administrator
Aprelium - http://www.aprelium.com


Last edited by admin on Fri Mar 13, 2009 4:56 pm; edited 1 time in total
Back to top
View user's profile Send private message
rrinc
-


Joined: 24 Feb 2006
Posts: 725
Location: Arkansas, USA

PostPosted: Thu Dec 11, 2008 11:24 pm    Post subject: Reply with quote

So far no issues. Good job getting it out this fast.
_________________
-Blake | New Server :D
SaveTheInternet
Soy hispanohablante. Puedes contactarme por mensajes privados.
Back to top
View user's profile Send private message Visit poster's website Yahoo Messenger MSN Messenger
Axis
-


Joined: 29 Sep 2003
Posts: 327

PostPosted: Fri Dec 12, 2008 6:36 pm    Post subject: Reply with quote

Is working fine for me. Thanks!

Regards,
Axis
Back to top
View user's profile Send private message
puertoblack2003
-


Joined: 08 Oct 2006
Posts: 87

PostPosted: Sat Dec 20, 2008 6:40 am    Post subject: Reply with quote

thanks for the update
Back to top
View user's profile Send private message
sonofcolin
-


Joined: 18 Nov 2004
Posts: 23

PostPosted: Tue Dec 23, 2008 1:05 am    Post subject: Reply with quote

Quote:
MacOS X version:

It takes more time to package and we do not expect to have it ready it before a few days.

As nothing has been packaged beyond 5.2.2 on OS X, I won't hold my breath for this version either. What's the problem? GCC 4.0 on OS X?
Back to top
View user's profile Send private message
admin
Site Admin


Joined: 03 Mar 2002
Posts: 718

PostPosted: Tue Dec 23, 2008 1:13 pm    Post subject: Reply with quote

sonofcolin,

The problem is that the build process for OS X is very cumbersome and requires always patches to be added (for PHP and for libraries it uses).

PHP for OS X is also not always well tested on old versions (10.2 and 10.3). So it takes time to fix the issues we encounter.

Keep also in mind that we have to package it as a self-contained universal binary while the standard build process for PHP assumes you are comiling on the computer you are going to deploy on and for a single arhcitecture.
_________________
Forum Administrator
Aprelium - http://www.aprelium.com
Back to top
View user's profile Send private message
DavidQ
-


Joined: 28 Jan 2009
Posts: 8

PostPosted: Wed Jan 28, 2009 6:55 pm    Post subject: Reply with quote

Hi,

my compliments on a great web server and many thanks for the recent update. I would appreciate your assistance with the following if possible.

I have just downloaded, installed and configured all the latest versions of...

1) Abyss Web Server 2.6
2) The preconfigured PHP 5.2.8 package for Windows
3) MySQL 5.1.3.0-community build
4) phpMyAdmin 3.1.2

On logging into phpMyAdmin I receive the following warning...

'(i) Your PHP MySQL library version 5.0.51a differs from your MySQL server version 5.1.30. This may cause unpredictable behavior.'

Does this mean that the preconfigured PHP 5.2.8 package for Windows requires MySQL 5.0.51a?

Is there perhaps a way of updating the PHP 5.2.8 package as installed to use a MySQL 5.1.30 library?

Thanks,

David
Back to top
View user's profile Send private message
rrinc
-


Joined: 24 Feb 2006
Posts: 725
Location: Arkansas, USA

PostPosted: Fri Jan 30, 2009 5:44 am    Post subject: Reply with quote

You're probably fine. I'm not sure, but you may be able to swap a dll and be up to date.
_________________
-Blake | New Server :D
SaveTheInternet
Soy hispanohablante. Puedes contactarme por mensajes privados.
Back to top
View user's profile Send private message Visit poster's website Yahoo Messenger MSN Messenger
jeffjohn
-


Joined: 02 May 2008
Posts: 38
Location: France 44290 or New Forest,UK

PostPosted: Sat Jan 31, 2009 12:11 pm    Post subject: Reply with quote

absolutely problem-free; well done to all!
Back to top
View user's profile Send private message
DavidQ
-


Joined: 28 Jan 2009
Posts: 8

PostPosted: Sun Feb 01, 2009 6:55 pm    Post subject: Reply with quote

Quote:
You're probably fine. I'm not sure, but you may be able to swap a dll and be up to date.


Thanks for the reply rrinc, for peace of mind though I would like a definitive answer. I'll send an email to Technical Support.

Best Regards,

David
Back to top
View user's profile Send private message
aprelium
-


Joined: 22 Mar 2002
Posts: 6800

PostPosted: Sun Feb 08, 2009 4:29 pm    Post subject: Reply with quote

DavidQ,

PhpMyAdmin did a quick version comparison (MySQL server version vs. PHP MySQL extension version) and reported a warning. But as far as we know, both will work together with no problems as there are no new features or changes in 5.1.30 that may break the compatibility with the PHP MySQL component.

So there should be no problem with the combination of both versions. We're already using it and we experienced no glitch.
_________________
Support Team
Aprelium - http://www.aprelium.com
Back to top
View user's profile Send private message Send e-mail
DavidQ
-


Joined: 28 Jan 2009
Posts: 8

PostPosted: Sun Feb 08, 2009 7:40 pm    Post subject: Reply with quote

Many thanks for the info.

Cheers,

David
Back to top
View user's profile Send private message
coolarmani
-


Joined: 22 Jan 2009
Posts: 8
Location: United Kingdom

PostPosted: Tue Mar 10, 2009 11:40 am    Post subject: Reply with quote

Hi,

PHP 5.2.9 was released on 26th February, is there a pre-configured package that I can download for this version?
Back to top
View user's profile Send private message
aprelium
-


Joined: 22 Mar 2002
Posts: 6800

PostPosted: Fri Mar 13, 2009 4:49 pm    Post subject: Reply with quote

coolarmani wrote:
Hi,

PHP 5.2.9 was released on 26th February, is there a pre-configured package that I can download for this version?


Sure: http://www.aprelium.com/forum/viewtopic.php?p=76720#76720
_________________
Support Team
Aprelium - http://www.aprelium.com
Back to top
View user's profile Send private message Send e-mail
reitchelazan
-


Joined: 30 May 2010
Posts: 1

PostPosted: Sun May 30, 2010 8:03 pm    Post subject: Reply with quote

I had catalist engine on win server 7 and it has a php module, and it do not wont to work on windows, so I decide install on freesbd and it's works. In windows it is mo kind of buggy.

восстановление зренияаудиокниги скачать бесплатномультфильмmp3 скачать бесплатноэлектрошокерБаза кинофильмов, кино, фильмы, анимация, мультики
Back to top
View user's profile Send private message
luzagodom
-


Joined: 11 Jun 2010
Posts: 1

PostPosted: Fri Jun 11, 2010 11:54 am    Post subject: Reply with quote

I like this thread. It ought to be made a sticky and a must read to all newbies.
Back to top
View user's profile Send private message Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic    Aprelium Forum Index -> PHP All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB phpBB Group