FAQ  |  Search  |  Register  |  Profile  |  Log in to check your private messages  |  Log in

Perl Script not found!

 
Post new topic   Reply to topic    Aprelium Forum Index -> Perl
View previous topic :: View next topic  
Author Message
cyber_gremlin
-


Joined: 13 Aug 2005
Posts: 9

PostPosted: Sat Aug 13, 2005 2:49 pm    Post subject: Perl Script not found! Reply with quote

Hi I am new to abyss web server and I have followed the instructions on the help page. I have set up the server, put the relevant documents in the htdocs folder and also put my perl script in the htdocs folder because cgi-bin does not exist. When ever I attempt to run my perl script I get this message...


http://localhost/Documents%20and%20Settings/The%20Family/My%20Documents/Fountain%20Of%20Life/mysqlPerl.pl

Page cannot be found.

Whats happening. Can you help.
Back to top
View user's profile Send private message
p3
-


Joined: 17 Jun 2005
Posts: 615

PostPosted: Sat Aug 13, 2005 3:08 pm    Post subject: Reply with quote

Just put the Perl Script in your htdocs folder. That's all you need to do, assuming that you have everything set up right.

The URL you have is for your localhost anyways, and unless you've made all those folders in htdocs, they aren't even broadcasted as files on your web server.

Hope this helps.

PS - Abyss doesn't need a cgi-bin folder, it already knows how to interpret it. If you have any more problems, I reccomend reading the tutorial at http://trustabyss.com to make sure you set everything up correctly.
Back to top
View user's profile Send private message Send e-mail
AbyssUnderground
-


Joined: 31 Dec 2004
Posts: 3855

PostPosted: Sat Aug 13, 2005 3:09 pm    Post subject: Reply with quote

You must put the script in the htdocs folder, by the look of the error it is in your My Documents folder. If it is not in the htdocs folder Abyss Web Server will not execute it.
_________________
Andy (AbyssUnderground) (previously The Inquisitor)
www.abyssunderground.co.uk
Back to top
View user's profile Send private message Visit poster's website
cyber_gremlin
-


Joined: 13 Aug 2005
Posts: 9

PostPosted: Sat Aug 13, 2005 4:06 pm    Post subject: 500 error Reply with quote

It says internal server error. Im lost.
Back to top
View user's profile Send private message
AbyssUnderground
-


Joined: 31 Dec 2004
Posts: 3855

PostPosted: Sat Aug 13, 2005 5:00 pm    Post subject: Reply with quote

Internal server error means the script is not set up properly or there is a programming error. Check cgi.log for the actually error.
_________________
Andy (AbyssUnderground) (previously The Inquisitor)
www.abyssunderground.co.uk
Back to top
View user's profile Send private message Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic    Aprelium Forum Index -> Perl All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB phpBB Group