FAQ  |  Search  |  Register  |  Profile  |  Log in to check your private messages  |  Log in

PPHMyAdmin - Error Logging In

 
Post new topic   Reply to topic    Aprelium Forum Index -> Databases
View previous topic :: View next topic  
Author Message
cenocre
-


Joined: 12 Mar 2007
Posts: 43

PostPosted: Tue May 01, 2012 9:45 pm    Post subject: PPHMyAdmin - Error Logging In Reply with quote

Setting up PHPMyAdmin for the first time. The log in page appears, but every time I try to log in I get:

Quote:
#1045 Cannot log in to the MySQL server
.

MySGL is running fine and I can log in both locally and remotely with various admin programs.

Any ideas?
Back to top
View user's profile Send private message
jxxaxxy
-


Joined: 11 Nov 2010
Posts: 26

PostPosted: Wed May 02, 2012 5:45 am    Post subject: Reply with quote

Really not enough info to help you.

Which version of mysql are you running.

Which version of php.

Are you upgrading from an old version of php/mysql.

Is the mysql server on same machine. If not then you will need to point it to the right server and use port 3306 if my memory serves me right.

So there could be a few issues. However, I run Abyss 2.7, mysql 5.5.23, php 5.3.10 and latest version of phpmyadmin. All on same machine with no issues. Generally you can log into it with no extra steps needed.

Also try dumping your temp files from your browser. Changing the blowfish will cause issues.
Back to top
View user's profile Send private message
cenocre
-


Joined: 12 Mar 2007
Posts: 43

PostPosted: Wed May 02, 2012 6:42 am    Post subject: Versions of Software Reply with quote

Abyss 2.7
PHP 5.3.8
MySQL 5.0.77
PHPMyAdmin 3.5.0

Running on same machine as Abyss.

Tried with and without this line in the config
Code:
$cfg['PmaAbsoluteUri'] = 'DOMAIN/scripts/phpmyadmin/';


and with this line as
Code:
$cfg['Servers'][$i]['host'] = '127.0.0.1';

and
Code:
$cfg['Servers'][$i]['host'] = 'localhost';


Not clear what you mean about "Changing the blowfish". Are you referring to encryption?
Code:
Back to top
View user's profile Send private message
jxxaxxy
-


Joined: 11 Nov 2010
Posts: 26

PostPosted: Wed May 02, 2012 10:33 pm    Post subject: Reply with quote

Yes encryption. I am betting the issue has to do with how you are connecting to mysql. I think by default phpmyadmin, at least newer version are connecting mysqli.

The mysqli extension is designed to work with MySQL version 4.1.13 or newer, or 5.0.7 or newer.

It show that your should be supported but you can try using mysql and see if that fixes the issue.

Try changing it to mysql and see if it will connect then.

Also did you try using it without any config setup with just default?

Also you are on a very old version of mysql. Any thought on upgrading to newer version 5.5???
Back to top
View user's profile Send private message
cenocre
-


Joined: 12 Mar 2007
Posts: 43

PostPosted: Wed May 02, 2012 11:02 pm    Post subject: Success Reply with quote

As I mentioned above I have tried the default, but the MySQLi may have been the initial problem.

Changing that still did not work.

My version of MySQL was supposed to have worked with PHPMyAdmin, but I did just upgrade to the latest version, 5.1.40 that works with PPC processors.

With just the single change to the default config from MySQLi to MySQL, it now works.

Thanks
Back to top
View user's profile Send private message
cenocre
-


Joined: 12 Mar 2007
Posts: 43

PostPosted: Wed May 02, 2012 11:03 pm    Post subject: Success Reply with quote

As I mentioned above I have tried the default, but the MySQLi may have been the initial problem.

Changing that still did not work.

My version of MySQL was supposed to have worked with PHPMyAdmin, but I did just upgrade to the latest version, 5.1.40 that works with PPC processors.

With just the single change to the default config from MySQLi to MySQL, it now works.

Thanks
Back to top
View user's profile Send private message
jxxaxxy
-


Joined: 11 Nov 2010
Posts: 26

PostPosted: Thu May 03, 2012 12:53 am    Post subject: Reply with quote

Good deal. I know with php 5.3 they made some changes in how it connects with myslnd being the default. This could also be an issue with your older version of database. But glad you got it going!!!
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    Aprelium Forum Index -> Databases All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB phpBB Group