FAQ  |  Search  |  Register  |  Profile  |  Log in to check your private messages  |  Log in

PHP Not Working on OSX

 
Post new topic   Reply to topic    Aprelium Forum Index -> PHP
View previous topic :: View next topic  
Author Message
FrigginGuy
-


Joined: 09 Mar 2009
Posts: 5

PostPosted: Mon Mar 09, 2009 4:40 pm    Post subject: PHP Not Working on OSX Reply with quote

I just installed the latest package of PHP for OS X from the install guide on this site. I've been away from web design/dev for a couple of years and I'm trying to get my server back up and running. I set up PHP according to Aprelium instructions and now the only PHP action I get is Error 500. I've done some snooping around, but haven't found a solution yet. I'm hoping someone can help me out here.

I'm running Abyss v2.5 on OS X Leopard (10.5.6). I tried getting a phpinfo() page to run on the root, but I get the same 500 error there. Let me know if you need any more information. Thanks in advance!
Back to top
View user's profile Send private message
DonQuichote
-


Joined: 24 Dec 2006
Posts: 68
Location: The Netherlands

PostPosted: Tue Mar 10, 2009 12:20 am    Post subject: Internal error Reply with quote

Error 500 is an internal error. It could be anything. If you can still use the administration site, set the abyss to log errors and warnings (you can set this near the CGI / FASTCGI parameters). Then try to reproduce the problem check the logs.
Back to top
View user's profile Send private message
FrigginGuy
-


Joined: 09 Mar 2009
Posts: 5

PostPosted: Tue Mar 10, 2009 8:22 pm    Post subject: Reply with quote

I enabled logging, and the only thing I see that looks like where the error is occurring says, "Reading 8 bytes failed = Broken pipe," which doesn't really mean anything to me. Does that suggest something to someone? Should I post the full text of one request on here?
Back to top
View user's profile Send private message
pkSML
-


Joined: 29 May 2006
Posts: 862
Location: Bucyrus, Ohio

PostPosted: Tue Mar 10, 2009 8:49 pm    Post subject: Reply with quote

Perhaps you have FastCGI enabled?

I'd suggest turning that off. See if it helps.
_________________
Stephen
Need a LitlURL?


My PBA sites | http://CodeBin.yi.org | http://Abyss-Websites.com
Back to top
View user's profile Send private message Visit poster's website Yahoo Messenger
FrigginGuy
-


Joined: 09 Mar 2009
Posts: 5

PostPosted: Tue Mar 10, 2009 9:10 pm    Post subject: Reply with quote

pkSML wrote:
Perhaps you have FastCGI enabled?

I'd suggest turning that off. See if it helps.


I'm not sure I follow. Are you saying set the Interface to something else?
Back to top
View user's profile Send private message
pkSML
-


Joined: 29 May 2006
Posts: 862
Location: Bucyrus, Ohio

PostPosted: Wed Mar 11, 2009 3:35 am    Post subject: Reply with quote

FrigginGuy wrote:
pkSML wrote:
Perhaps you have FastCGI enabled?

I'd suggest turning that off. See if it helps.


I'm not sure I follow. Are you saying set the Interface to something else?


Correct. Set the interface to CGI/ISAPI.

You've stumbled upon one of many, many issues with FastCGI. It might save you 2/1000's of a second on a script's execution time over plain CGI, but it can just stop working all of the sudden and/or bring your server to a halt. Search the forum and you'll see why I just prefer to stick with regular old CGI!
_________________
Stephen
Need a LitlURL?


My PBA sites | http://CodeBin.yi.org | http://Abyss-Websites.com
Back to top
View user's profile Send private message Visit poster's website Yahoo Messenger
FrigginGuy
-


Joined: 09 Mar 2009
Posts: 5

PostPosted: Wed Mar 11, 2009 5:29 pm    Post subject: Reply with quote

I've tried that before, and I just tried it again upon your suggestion. No joy either time. I've also played around with the type setting and different combinations of the two settings.
Back to top
View user's profile Send private message
pkSML
-


Joined: 29 May 2006
Posts: 862
Location: Bucyrus, Ohio

PostPosted: Wed Mar 11, 2009 7:35 pm    Post subject: Reply with quote

Hmmmm....

Must be a problem with the pre-configured package or your particular Mac setup.

I recommend switching to Windows! :-) Just kidding...

You could email Aprelium support about it, since very few forum members have a Mac setup.
_________________
Stephen
Need a LitlURL?


My PBA sites | http://CodeBin.yi.org | http://Abyss-Websites.com
Back to top
View user's profile Send private message Visit poster's website Yahoo Messenger
aprelium-support
-


Joined: 20 Feb 2009
Posts: 355

PostPosted: Thu Mar 12, 2009 11:35 am    Post subject: Reply with quote

FrigginGuy,

What do you get when you do the following:
* Open the Terminal application (from Applications/Utilities)
* Type:

/Applications/PHP5/bin/php

* If there are no errors and the cursor is moved to the next line, press:

CTRL + D

* What is the output you get at that stage? If there are any errors, please copy and paste them here.
_________________
Support Team
Aprelium - http://www.aprelium.com
Back to top
View user's profile Send private message Visit poster's website
FrigginGuy
-


Joined: 09 Mar 2009
Posts: 5

PostPosted: Thu Mar 12, 2009 8:44 pm    Post subject: Reply with quote

When I run it, it goes to the next line and just sits there. When I hit CTRL D, it gives me this:

Code:
X-Powered-By: PHP/5.2.2
Content-type: text/html


That's all. :-S
Back to top
View user's profile Send private message
aprelium-support
-


Joined: 20 Feb 2009
Posts: 355

PostPosted: Fri Mar 13, 2009 11:27 am    Post subject: Reply with quote

FrigginGuy,

You seem to have a configuration problem, please send your abyss.conf and php.ini files to the Technical Support contact :
http://www.aprelium.com/support/standard/
_________________
Support Team
Aprelium - http://www.aprelium.com
Back to top
View user's profile Send private message Visit poster's website
BigMac
-


Joined: 24 Mar 2007
Posts: 2

PostPosted: Tue Mar 24, 2009 12:52 pm    Post subject: Reply with quote

I have another problem whit X2 Leopard ( full updatet ) and the aprelium php 522 image .
output console inkl. ls
Apfels:~ apfel$ /Applications/PHP5/bin/php
dyld: Library not loaded: /usr/lib/libiodbc.2.1.6.dylib
Referenced from: /Applications/PHP5/bin/php
Reason: image not found
Trace/BPT trap
Apfels:~ apfel$ ls /usr/lib/libiodbc.
libiodbc.2.1.17.dylib libiodbc.2.dylib libiodbc.dylib

and in fastcgi.log :
SUID: 1 PUID: 1 RUID: 1 URI: /index.php Reading 8 bytes failed = Broken pipe

any new php-precompile image for mac os users ?

EDIT :
fix the issus :
Code:

sudo ln -s /usr/lib/libiodbc.2.1.17.dylib /usr/lib/libiodbc.2.1.6.dylib
sudo ln -s /usr/lib/libpanel.5.4.dylib /usr/lib/libpanel.5.dylib

end
hope thats help other users.
Back to top
View user's profile Send private message
sonofcolin
-


Joined: 18 Nov 2004
Posts: 23

PostPosted: Wed Mar 25, 2009 11:46 am    Post subject: Reply with quote

I have managed to install php5.2.9 on an intel and ppc mac using macports. Both build and install without issue on both machines. Both builds are identical in configuration.

The intel build works with Abyss. Here are the settings:
Code:
Darwin Macintosh-3.local 9.6.0 Darwin Kernel Version 9.6.0: Mon Nov 24 17:37:00 PST 2008; root:xnu-1228.9.59~1/RELEASE_I386 i386
Build Date    Mar 25 2009 13:00:33
Configure Command    './configure' '--prefix=/opt/local' '--mandir=/opt/local/share/man' '--infodir=/opt/local/share/info' '--with-config-file-path=/opt/local/etc' '--enable-calendar' '--with-iconv=/opt/local' '--enable-exif' '--enable-ftp' '--enable-wddx' '--with-zlib=/opt/local' '--with-bz2=/opt/local' '--without-mysql' '--without-sqlite' '--without-pdo-sqlite' '--with-libxml-dir=/opt/local' '--with-gettext=/opt/local' '--with-xml' '--with-libexpat-dir=/opt/local' '--with-xmlrpc' '--enable-soap' '--enable-bcmath' '--enable-mbstring' '--enable-dba' '--enable-zip' '--with-openssl=/opt/local' '--with-mhash=/opt/local' '--with-mcrypt=/opt/local' '--with-mime-magic' '--with-xsl=/opt/local' '--with-curl=/opt/local' '--with-pcre-regex=/opt/local' '--with-gd' '--with-jpeg-dir=/opt/local' '--with-png-dir=/opt/local' '--enable-gd-native-ttf' '--without-pear' '--with-freetype-dir=/opt/local' '--with-ldap=/usr' '--with-kerberos=/usr' '--with-iodbc=/usr' '--enable-fastcgi' '--enable-force-cgi-redirect'

php is set to use local pipes with fastcgi

The PPC build does not work with Abyss. From fastcgi log:
Code:
25/Mar/2009:03:24:32 -0700   SUID: 0   PUID: 0   RUID: 1   URI: /testing123.php   Reading 8 bytes failed = Broken pipe
25/Mar/2009:03:28:58 -0700   SUID: 0   PUID: 0   RUID: 0   URI:    Reading 0 bytes failed = Broken pipe
25/Mar/2009:03:28:58 -0700   SUID: 0   PUID: 0   RUID: 0   URI:    timeout-header2!
25/Mar/2009:03:29:31 -0700   SUID: 1   PUID: 1   RUID: 0   URI:    Reading 0 bytes failed = Broken pipe
25/Mar/2009:03:29:31 -0700   SUID: 1   PUID: 1   RUID: 0   URI:    timeout-header2!


Both build environments are also identical (Macports takes care of that). So, my test server works a charm with 5.2.9 and my deployment environment is still broken :(


Last edited by sonofcolin on Wed Mar 25, 2009 1:35 pm; edited 1 time in total
Back to top
View user's profile Send private message
sonofcolin
-


Joined: 18 Nov 2004
Posts: 23

PostPosted: Wed Mar 25, 2009 12:02 pm    Post subject: Reply with quote

BigMac wrote:


any new php-precompile image for mac os users ?

Yes - install macports. Then:
Code:
sudo install php5 +fastcgi

Make a cup of tea.
Change scripting parameters interface to Fast-cgi local pipes and the Interpreter to /opt/local/bin/php-cgi

Works on my Intel mac with Abyss 2.6, not on PPC 10.4.11
Back to top
View user's profile Send private message
Denis
-


Joined: 29 Jan 2008
Posts: 12

PostPosted: Mon May 31, 2010 4:14 am    Post subject: PPC troubles Reply with quote

PHP used to work great on my PPC machine at home, but after upgrading it from 10.4 to 10.5.8 I get those error 500 redirects whenever I try to go to any .php file.

I have a bad feeling there's something up with 10.5.8, Abyss and PPC machines and PHP. I'm using all the latest Abyss stuff and the PHP 5.x was downloaded from here too.

Ugh... I used to love using my old PPC as a PHP testing server. No more?
Back to top
View user's profile Send private message
thimothy
-


Joined: 29 Oct 2010
Posts: 5

PostPosted: Fri Nov 05, 2010 12:03 pm    Post subject: Reply with quote

I think the problem here is with MAC set up. I am sorry to say that I will not able to give a convincing answer to his query because I do not use MAC. I would advise him to switch to Windows because it is convenient and highly user friendly. I know that my suggestion will seem ridiculous to him. I switched from MAC to Windows some time ago because of constant problems with relation to my server. But now there is no problem and I have peace of mind.
_________________
Multivariate Testing
Back to top
View user's profile Send private message
cenocre
-


Joined: 12 Mar 2007
Posts: 43

PostPosted: Wed Nov 10, 2010 3:11 am    Post subject: PHP works fine on 10.5.8 Reply with quote

Since thimothy opened a very old thread that was apparently not resolved, it may be important to let people know that PHP (Aprelium's build) and Abyss work great on OS X.
Been using it for years on Macs in a commercial environment. It works fine on 10.5.8 on every machine I have ever tried. I did have some error 500 problems the first time on Leopard, but I may have been using a different build.

ALL that I had to do is use Aprelium's PHP 5.5.2 with the following config:

Quote:
Interface - Interpreter
FastCGI (Local - Pipes) - /Applications/PHP5/bin/php

and put PHP in this path:

Quote:
/Applications/PHP5


In the rare case that you do have a problem you may want to check permissions on the PHP5 folder.

I'll be trying a more up-to-date version of PHP soon and see if that works.


thimothy, it would be nice to keep out of OS proselytizing in a forum like this. Besides, it is a bit surprising that if you used Macs as you stated AND you are involved in running servers that you don't know the difference between MAC and Mac.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    Aprelium Forum Index -> PHP All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB phpBB Group