FAQ  |  Search  |  Register  |  Profile  |  Log in to check your private messages  |  Log in

Preconfigured PHP 5.2.10 for Windows package ready for tests

 
Post new topic   Reply to topic    Aprelium Forum Index -> PHP
View previous topic :: View next topic  
Author Message
aprelium
-


Joined: 22 Mar 2002
Posts: 6800

PostPosted: Fri Jul 17, 2009 2:29 pm    Post subject: Preconfigured PHP 5.2.10 for Windows package ready for tests Reply with quote

Dear all,

PHP 5.2.10 has been released during early July and fixes several problems in 5.2.9 while improving several features: http://www.php.net/ChangeLog-5.php .

The preconfigured PHP 5.2.10 package for Windows is available from: http://www.aprelium.com/data/php5210.exe .

Please give it a try and let us know if it works fine for you.

The installation instructions are similar to those in http://www.aprelium.com/abyssws/php5win.html with one major exception: Type must be set to Standard

READ THIS IF YOU ARE UPGRADING:

If you are upgrading from an old preconfigured PHP package do not forget to set Type to Standard in the interpreter declaration.

A NOTE ABOUT PHP 5.3:

Due to several major changes in PHP 5.3, we are still testing it and a preconfigured PHP 5.2.3 package will be made available very soon.
_________________
Support Team
Aprelium - http://www.aprelium.com
Back to top
View user's profile Send private message Send e-mail
TRUSTAbyss
-


Joined: 29 Oct 2003
Posts: 3694
Location: USA, GA

PostPosted: Thu Jul 23, 2009 6:37 am    Post subject: Reply with quote

I haven't had time to test this one yet because I'm waiting on my notebook to return from the service repair center. They're replacing my display screen because of a dead pixel). I will test this as soon as I get the notebook home.
_________________
Networking Specialist and Web Developer

Back to top
View user's profile Send private message Visit poster's website MSN Messenger
Axis
-


Joined: 29 Sep 2003
Posts: 328

PostPosted: Thu Jul 23, 2009 6:26 pm    Post subject: Reply with quote

Aprelium--

I have been using the new php download since the day it appeared and everything I have that uses php has worked fine.

I thought you might like a little feedback.

Regards,
Axis


Last edited by Axis on Thu Oct 31, 2013 5:29 pm; edited 1 time in total
Back to top
View user's profile Send private message
Toasty
-


Joined: 21 Feb 2008
Posts: 285
Location: Chicago, IL

PostPosted: Sat Aug 01, 2009 5:56 am    Post subject: Reply with quote

Using it now, works great.
_________________
Portfolio: Robert Lerner
Back to top
View user's profile Send private message Visit poster's website
Mass Zero
-


Joined: 28 Apr 2008
Posts: 2

PostPosted: Sun Aug 16, 2009 12:58 pm    Post subject: Reply with quote

Please release a new version of Current PHP 5.3 Stable: 5.3.0
cause the PHP 5.2.10 only support mysql 5.0

Dont mind the first error lol...


Thx... more power to Abyss Web Server!
Back to top
View user's profile Send private message
Mass Zero
-


Joined: 28 Apr 2008
Posts: 2

PostPosted: Wed Aug 19, 2009 10:40 am    Post subject: Reply with quote

Anybody home? someone kindly make a new reconfigure PHP i think its about time... LOL!!
Back to top
View user's profile Send private message
TRUSTAbyss
-


Joined: 29 Oct 2003
Posts: 3694
Location: USA, GA

PostPosted: Sun Aug 23, 2009 7:02 am    Post subject: Reply with quote

PHP 5.3 is still very new and needs more testing on Aprelium's side. Please be patient and it will be here soon.
_________________
Networking Specialist and Web Developer

Back to top
View user's profile Send private message Visit poster's website MSN Messenger
reefbum
-


Joined: 25 May 2007
Posts: 9
Location: FL

PostPosted: Sat Nov 07, 2009 8:01 am    Post subject: PCI Compliance Reply with quote

Using 5.2.10 with no issues so far.

However SecurityMetrics.com performs my PCI compliance security scans for my credit card processing in my shopping cart is failing my PCI compliance security scan. They are reporting security issues with PHP5.2.10 and said I need to upgrade to 5.2.11

My merchant account bank has given me 15days to become compliant again or they will halt my merchant account and said I could get fines from Visa and Mastercard up to $25K

What is the best way to upgrade to 5.2.11 so I can pass the PCI compliance security scans?
Back to top
View user's profile Send private message Yahoo Messenger MSN Messenger
TRUSTAbyss
-


Joined: 29 Oct 2003
Posts: 3694
Location: USA, GA

PostPosted: Sat Nov 07, 2009 3:05 pm    Post subject: Reply with quote

You should be able to manually install it. Have a look at my website (trustabyss.com) or the website for my banner and try the installation instructions. If that doesn't work, it is best to contact Aprelium directly, regarding this issue.

Sincerely, Joshua H.
_________________
Networking Specialist and Web Developer

Back to top
View user's profile Send private message Visit poster's website MSN Messenger
aprelium-support
-


Joined: 20 Feb 2009
Posts: 348

PostPosted: Mon Nov 09, 2009 11:27 am    Post subject: Re: PCI Compliance Reply with quote

reefbum wrote:

What is the best way to upgrade to 5.2.11 so I can pass the PCI compliance security scans?


The following 5.2.11 package is still under tests but we had no issues with it until now, you can try it:

http://www.aprelium.com/data/php5211.exe
_________________
Support Team
Aprelium - http://www.aprelium.com


Last edited by aprelium-support on Thu May 20, 2010 9:58 am; edited 1 time in total
Back to top
View user's profile Send private message Visit poster's website
Toasty
-


Joined: 21 Feb 2008
Posts: 285
Location: Chicago, IL

PostPosted: Fri Nov 13, 2009 2:27 pm    Post subject: Reply with quote

I'm currently using the 5.2.11 from Aprelium, seems to work just fine.

While I was waiting for an upgrade to this, I tried the 5.3 package from php.net, and while it worked, I found a few problems with it:

- Depreciates ereg--- functions, and you should use preg---. Kind of a pain since most of my $_GET request handling was with ereg, but it will help future proof me for PHP 6, which removes ereg completely.

- There's some odd time zone problem, where you're requred to have it set in PHP.INI. I did have it set, and also the LAT/LONG, I tried in and outside of quotes, and even using a function inside of my scripts to set it if PHP.INI wasn't read right. To my dismay, it killed my sites great speed when it would be writting several megabytes to the error log telling me I'm "*REQUIRED* TO USE THE TIME ZONE SETTING IN PHP" or whatever. A bit of a hassle.


Just a few things to look for when >= PHP 5.3 starts coming in.
_________________
Portfolio: Robert Lerner
Back to top
View user's profile Send private message Visit poster's website
t0t0m@n
-


Joined: 06 May 2010
Posts: 1

PostPosted: Thu May 06, 2010 7:47 pm    Post subject: PHP Expiration Reply with quote

Hi,

I am currently using Abyss Web Server X1 and PHP. I just want to know, if there is some kind of expiration for my PHP. I used the preconfigured package. I have been asking this because, before this, i was using classic ASP but was disappointed to know that the Activehtml software was only good for 45 days.
Back to top
View user's profile Send private message
aprelium-support
-


Joined: 20 Feb 2009
Posts: 348

PostPosted: Thu May 20, 2010 9:57 am    Post subject: Re: PHP Expiration Reply with quote

t0t0m@n wrote:
Hi,

I am currently using Abyss Web Server X1 and PHP. I just want to know, if there is some kind of expiration for my PHP. I used the preconfigured package. I have been asking this because, before this, i was using classic ASP but was disappointed to know that the Activehtml software was only good for 45 days.



There is no expiration for PHP.
_________________
Support Team
Aprelium - http://www.aprelium.com
Back to top
View user's profile Send private message Visit poster's website
golowenow
-


Joined: 29 Apr 2004
Posts: 34
Location: Washington state

PostPosted: Sun Aug 15, 2010 12:27 am    Post subject: PHP 5.3 Reply with quote

PHP 5.2x has reached the end of its support cycle and is now outdated. Please enact all resources into creating the preconfigured package for the 5.3 versions.
Thank you
Back to top
View user's profile Send private message Visit poster's website
Toasty
-


Joined: 21 Feb 2008
Posts: 285
Location: Chicago, IL

PostPosted: Mon Sep 27, 2010 7:54 pm    Post subject: Reply with quote

Aprelium is not responsible for providing PHP packages, they do this merely as a convenience to forum users.

The PHP package you get from php.net works perfectly. When installing, select the extensions you require, and make sure to select "Other CGI" for the servers, not IIS or Apache, or "No server now."

This will extract the php-cgi.exe, which you'll need to interface with Abyss. I'm assuming you're looking for a Windows platform, since Linux archives have never originated from this site, and are generally compiled on a per-server basis per requirements. I typically use Non-Thread Safe VS6, however you may find better results with one of the other available packages.

Windows PHP Downloads

Additionally, PHP 5.2.x is not unsupported, with the 5.2.14 release coming out on July 22nd. You should consider PHP 5.3.3, but I'm willing to bet you'll regret it if you're not an experienced PHP developer.
_________________
Portfolio: Robert Lerner
Back to top
View user's profile Send private message Visit poster's website
admin
Site Admin


Joined: 03 Mar 2002
Posts: 718

PostPosted: Tue Sep 28, 2010 6:33 pm    Post subject: Re: PHP 5.3 Reply with quote

golowenow wrote:
PHP 5.2x has reached the end of its support cycle and is now outdated. Please enact all resources into creating the preconfigured package for the 5.3 versions.
Thank you


5.3 has been very problematic when it was first released. That's why we continued publishing 5.2.x packages.

Now that 5.2.x has been phased out, we'll make 5.3 builds public. Thank you for bringing that to our attention.

You can already download http://www.aprelium.com/data/php531.exe which is the package we built for PHP 5.3.1.
_________________
Forum Administrator
Aprelium - http://www.aprelium.com
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    Aprelium Forum Index -> PHP All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB phpBB Group