FAQ  |  Search  |  Register  |  Profile  |  Log in to check your private messages  |  Log in

Cannot running Moodle over Abyss

 
Post new topic   Reply to topic    Aprelium Forum Index -> General Questions
View previous topic :: View next topic  
Author Message
c0r2ar0
-


Joined: 06 Oct 2007
Posts: 44

PostPosted: Wed Nov 16, 2011 7:55 am    Post subject: Cannot running Moodle over Abyss Reply with quote

Hi all,
one of our customers hosted on our server, needs to run Moodle CMS.
During the installation process it says:

Web server software (Abyss/2.7.0.0-X2-Win32 AbyssLib/2.7.0.0) is not supported, sorry.

I have run almost everything on our web server, I thought Abyss was compatible with everything.

Someone can help me fixing this problem?

Thanks in advance for anyone will help,
Paolo
Back to top
View user's profile Send private message
jxxaxxy
-


Joined: 11 Nov 2010
Posts: 26

PostPosted: Wed Nov 16, 2011 7:23 pm    Post subject: Reply with quote

This has to do with the moodle software itself and not abyss. You will need to find a way to bypass the requirement section of moodle.
Back to top
View user's profile Send private message
TRUSTAbyss
-


Joined: 29 Oct 2003
Posts: 3705
Location: USA, GA

PostPosted: Thu Nov 17, 2011 2:55 am    Post subject: Reply with quote

Moodle is probably aimed at a specific server software. You might be able to change the source code to allow Abyss to install. Hang in there, I'm testing the software to see if I can install it. If not, I will try and change the source code. ;-)

UPDATE 11/18/2012
I can't believe I put this off for a year. Anyway, instructions for getting Moodle to work with Abyss has been posted.

UPDATE 11/18/2011
The file moodle\lib\setuplib.php contains the server software compatibility code. I added an extra else if to allow Abyss Web Server but it is still complaining of some things that are required like Unicode. Let me look into it some more and I will show you how to add it to Abyss. Hang in there, help is on the way!

Success! Moodle has been successfully installed on Abyss Web Server. I'm writing the instructions on how to do this. It will be available as soon as I have the time.

Screenshot:

_________________
Networking Specialist and Web Developer



Last edited by TRUSTAbyss on Sun Nov 18, 2012 9:13 pm; edited 2 times in total
Back to top
View user's profile Send private message Visit poster's website MSN Messenger
R.Peters
-


Joined: 16 Nov 2012
Posts: 3
Location: Netherlands

PostPosted: Fri Nov 16, 2012 3:37 pm    Post subject: Moodle not supported Abyss Web Server Reply with quote

Hello TRUSTAbyss

Have the same issue as you described
With the installation of Moodle 2.3 I get the following message.

Web server software (Abyss/2.7.0.0-X2-Win32 AbyssLib/2.7.0.0) is not supported, sorry.

Do you have the time and please would you tell me what kind of solution you have found, what you have add or what you have changed at the source code so that it will install Moodle 2.3.

Thanks
Remco
Back to top
View user's profile Send private message
R.Peters
-


Joined: 16 Nov 2012
Posts: 3
Location: Netherlands

PostPosted: Sat Nov 17, 2012 10:32 am    Post subject: Moodle not supported Abyss Web Server Reply with quote

Hello TRUSTAbyss

I've previously posted a message, in reply, but I think something went wrong.

I've been using Abyss Web Server X2 for about 7 years now and I've never had a question before, thanks to this forum and Internet, until now.
Searching this forum, the Moodle forum and the Internet about this issue but only I found your post with a possible solution. I do not get any support from the Moodle site or even any response, so I stay with a problem. I do not want to make my problem yours.. (lol). But, because I read that you “maybe” have the solution, I ask it to you.

It was yours succeed to bypass this notification, but how ?
Please can you help me with an answer to my question ?
What have you adapted or added to the file moodle\lib\setuplib.php ?

Earlier versions of Moodle, as an example v1.9, does not have this problem. But I want to be up to date because the Moodle v2.3 has much more possibilities, if it arrives on education.

Friendly thanks in advance.

Remco
_________________
There's always a solution for every problem.
Back to top
View user's profile Send private message
TRUSTAbyss
-


Joined: 29 Oct 2003
Posts: 3705
Location: USA, GA

PostPosted: Sun Nov 18, 2012 9:00 pm    Post subject: Reply with quote

PREPPING MOODLE FOR ABYSS WEB SERVER

WARNING! Before you start, make sure you install PHP, MySQL, and phpMyAdmin.

1. Open phpMyAdmin and create a new database named "moodle" (without the quotes) and set its encoding to "utf8_general_ci" (faster) or "utf8_unicode_ci" (slower but accurate)

2. Download Moodle from moodle.org and save the archived ZIP file to your htdocs (or wherever you put your web documents). Extract the moodle folder.

3. Browse to the moodle folder followed by the lib folder. Open the setuplib.php file in a code editor such as Notepad++ and scroll down to line 866. Make the following changes

Code:

} else if (stripos($_SERVER['SERVER_SOFTWARE'], 'lighttpd') !== false) {

to this
Code:

} else if (stripos($_SERVER['SERVER_SOFTWARE'], 'abyss') !== false) {

4. Save your changes.

5. Open the php.ini file under the root of your PHP folder and search for the string "extension_dir" until you come to extension_dir = "ext" and uncomment it by removing the semicolon. Uncomment the following extensions by removing the prefixed semicolon:

extension=php_mysql.dll
extension=php_mysqli.dll
extension=php_curl.dll
extension=php_mbstring.dll
extension=php_openssl.dll
extension=php_xmlrpc.dll
extension=php_soap.dll
extension=php_gd2.dll
extension=php_intl.dll

6. Save changes and run the setup according to the moodle setup instructions.

NOTE: If the page times out during installation, modify the CGI and FastCGI timeout to a higher number like 900 seconds.

Success! Right? :)
_________________
Networking Specialist and Web Developer



Last edited by TRUSTAbyss on Mon Nov 19, 2012 11:59 pm; edited 1 time in total
Back to top
View user's profile Send private message Visit poster's website MSN Messenger
R.Peters
-


Joined: 16 Nov 2012
Posts: 3
Location: Netherlands

PostPosted: Mon Nov 19, 2012 11:16 pm    Post subject: Reply with quote

Hello TRUSTAbyss,

I want to thank you for your time and the clear instructions.
I have Installed it and it works!

An additional minor adjustment.
During the installation I got the following message:

"Could not find a top-level course"
After that, it was a little bit quiet.

Some searching the Internet I came across the following. The page was timing out and I have to change, in Abyss Web Server, the FastCGI Processes Timeout longer and set it to 900 Second(s) instead of 240 Second(s).
Everything removed and restarted and after a while it ended with the data page.

Done.

Respectfully

Remco
_________________
There's always a solution for every problem.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    Aprelium Forum Index -> General Questions All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB phpBB Group